The server is being loaded up.
Incident Report for HNG Network
Resolved
RESOLVED - HotelNovemberGolf
Posted Jun 03, 2020 - 18:40 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 03, 2020 - 18:32 UTC
Monitoring
This is new, please wait before connecting.
Posted Jun 03, 2020 - 18:32 UTC
This incident affected: Games (Minecraft Server 2).